import Foundation
let pattern = #"""
^/sale/([0-9]{4}|4x4|awd|cars|chrysler|dodge|jeep|ram|suv|truck|van)[a-z0-9-]+(\?.*?)?$
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Goal Completion Location
/sale/used-cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/ram-bismarck-nd
/sale/ram-1500-bismarck-nd
/sale/jeep-bismarck-nd
/sale/ram-2500-bismarck-nd
/sale/ram-1500-big-horn-night-edition-bismarck-nd
/sale/ram-1500-laramie-night-edition-bismarck-nd
/sale/jeep-grand-cherokee-bismarck-nd
/sale/jeep-wrangler-bismarck-nd
/sale/dodge-bismarck-nd
/sale/ram-1500-big-horn-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/ram-3500-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/chrysler-pacifica-bismarck-nd
/sale/ram-1500-rebel-bismarck-nd
/sale/used-ram-bismarck-nd
/sale/jeep-gladiator-bismarck-nd
/sale/dodge-durango-bismarck-nd
/sale/ram-2500-laramie-bismarck-nd
/sale/truck-bismarck-nd
/sale/ram-1500-warlock-bismarck-nd
/sale/jeep-renegade-bismarck-nd
/sale/used-truck-bismarck-nd
/sale/jeep-compass-bismarck-nd
/sale/2020-ram-bismarck-nd
/sale/ram-1500-big-horn-builttoserve-edition-bismarck-nd
/sale/used-jeep-bismarck-nd
/sale/used-ram-1500-bismarck-nd
/sale/jeep-wrangler-unlimited-rubicon-bismarck-nd
/sale/jeep-grand-cherokee-limited-bismarck-nd
/sale/dodge-charger-bismarck-nd
/sale/2021-ram-bismarck-nd
/sale/used-ram-2500-bismarck-nd
/sale/used-chevrolet-bismarck-nd
/sale/ram-1500-laramie-bismarck-nd
/sale/ram-1500-big-horn-built-to-serve-edition-bismarck-nd
/sale/ram-1500-laramie-sport-bismarck-nd
/sale/ram-2500-laramie-mega-cab-night-edition-bismarck-nd
/sale/used-ford-bismarck-nd
/sale/ram-2500-power-wagon-bismarck-nd
/sale/used-jeep-wrangler-bismarck-nd
/sale/used-dodge-bismarck-nd
/sale/used-ram-1500-laramie-bismarck-nd
/sale/used-jeep-grand-cherokee-bismarck-nd
/sale/2021-jeep-bismarck-nd
/sale/dodge-challenger-bismarck-nd
/sale/ram-2500-tradesman-bismarck-nd
/sale/dodge-journey-bismarck-nd
/sale/2020-jeep-bismarck-nd
/sale/2021-ram-1500-rebel-bismarck-nd
/sale/jeep-cherokee-latitude-lux-bismarck-nd
/sale/ram-1500-limited-bismarck-nd
/sale/ram-1500-big-horn-sport-bismarck-nd
/sale/used-toyota-bismarck-nd
/sale/jeep-cherokee-trailhawk-bismarck-nd
/sale/used-dodge-challenger-bismarck-nd
/sale/2020-bismarck-nd
/sale/used-suv-bismarck-nd
/sale/ram-truck-bismarck-nd
/sale/chrysler-bismarck-nd
/sale/used-ford-f150-bismarck-nd
/sale/jeep-cherokee-limited-bismarck-nd
/sale/used-chevrolet-silverado-1500-bismarck-nd
/sale/used-dodge-ram-2500-bismarck-nd
/sale/ram-2500-big-horn-bismarck-nd
/sale/ram-3500-laramie-bismarck-nd
/sale/jeep-wrangler-unlimited-sport-80th-anniversary-bismarck-nd
/sale/used-ram-1500-big-horn-bismarck-nd
/sale/2021-ram-1500-bismarck-nd
/sale/jeep-grand-cherokee-laredo-x-bismarck-nd
/sale/used-ram-3500-bismarck-nd
/sale/jeep-wrangler-unlimited-sport-bismarck-nd
/sale/used-subaru-bismarck-nd
/sale/jeep-gladiator-rubicon-bismarck-nd
/sale/used-chrysler-bismarck-nd
/sale/used-chrysler-pacifica-bismarck-nd
/sale/used-awd-bismarck-nd
/sale/ram-3500-tradesman-bismarck-nd
/sale/used-jeep-cherokee-bismarck-nd
/sale/used-ram-2500-laramie-bismarck-nd
/sale/used-van-bismarck-nd
/sale/jeep-wrangler-unlimited-sahara-bismarck-nd
/sale/used-nissan-bismarck-nd
/sale/used-dodge-charger-bismarck-nd
/sale/used-gmc-sierra-1500-bismarck-nd
/sale/2020-ram-1500-bismarck-nd
/sale/ram-5500hd-bismarck-nd
/sale/used-honda-bismarck-nd
/sale/2021-ram-1500-warlock-bismarck-nd
/sale/used-chevrolet-corvette-bismarck-nd
/sale/used-jeep-renegade-bismarck-nd
/sale/ram-2500-limited-bismarck-nd
/sale/used-2013-bismarck-nd
/sale/used-ford-escape-bismarck-nd
/sale/jeep-grand-cherokee-laredo-e-bismarck-nd
/sale/jeep-renegade-trailhawk-bismarck-nd
/sale/used-ford-super-duty-f250-bismarck-nd
/sale/used-honda-accord-bismarck-nd
/sale/2021-ram-2500-bismarck-nd
/sale/used-dodge-durango-bismarck-nd
/sale/used-toyota-rav4-bismarck-nd
/sale/chrysler-pacifica-launch-edition-bismarck-nd
/sale/jeep-compass-latitude-bismarck-nd
/sale/jeep-gladiator-mojave-bismarck-nd
/sale/jeep-gladiator-sport-bismarck-nd
/sale/jeep-grand-cherokee-trailhawk-bismarck-nd
/sale/used-cadillac-bismarck-nd
/sale/used-jeep-compass-bismarck-nd
/sale/used-ram-1500-laramie-longhorn-bismarck-nd
/sale/ram-promaster-2500-bismarck-nd
/sale/2020-dodge-bismarck-nd
/sale/chrysler-300-bismarck-nd
/sale/jeep-compass-trailhawk-bismarck-nd
/sale/ram-1500-big-hornlone-star-bismarck-nd
/sale/ram-1500-limited-night-edition-bismarck-nd
/sale/used-chevrolet-colorado-bismarck-nd
/sale/used-2018-ram-bismarck-nd
/sale/2020-jeep-renegade-bismarck-nd
/sale/dodge-charger-gt-bismarck-nd
/sale/jeep-grand-cherokee-high-altitude-bismarck-nd
/sale/used-2020-jeep-bismarck-nd
/sale/used-ram-2500-laramie-longhorn-bismarck-nd
/sale/2021-bismarck-nd
/sale/2021-jeep-grand-cherokee-laredo-e-bismarck-nd
/sale/jeep-grand-cherokee-overland-bismarck-nd
/sale/used-2015-jeep-bismarck-nd
/sale/used-chevrolet-tahoe-bismarck-nd
/sale/used-chrysler-300-bismarck-nd
/sale/used-ford-f150-lariat-bismarck-nd
/sale/used-gmc-bismarck-nd
/sale/used-jeep-bismarck-nd
/sale/used-subaru-forester-bismarck-nd
/sale/used-toyota-tundra-bismarck-nd
/sale/truck-bismarck-nd
/sale/used-cadillac-escalade-bismarck-nd
/sale/used-chevrolet-traverse-bismarck-nd
/sale/used-ford-edge-bismarck-nd
/sale/used-honda-cr-v-bismarck-nd
/sale/used-hyundai-bismarck-nd
/sale/used-ram-1500-slt-bismarck-nd
/sale/2020-jeep-cherokee-bismarck-nd
/sale/2021-jeep-cherokee-bismarck-nd
/sale/2021-jeep-grand-cherokee-bismarck-nd
/sale/2021-ram-3500-bismarck-nd
/sale/certified-cars-bismarck-nd
/sale/jeep-renegade-limited-bismarck-nd
/sale/used-2015-ram-bismarck-nd
/sale/used-4x4-bismarck-nd
/sale/used-cadillac-xt4-bismarck-nd
/sale/used-chevrolet-silverado-2500hd-bismarck-nd
/sale/used-jeep-grand-cherokee-altitude-bismarck-nd
/sale/2021-jeep-renegade-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-compass-limited-bismarck-nd
/sale/jeep-grand-cherokee-limited-80th-anniversary-bismarck-nd
/sale/jeep-renegade-sport-bismarck-nd
/sale/used-2016-jeep-bismarck-nd
/sale/used-2017-ram-1500-bismarck-nd
/sale/used-2019-ram-1500-bismarck-nd
/sale/used-chevrolet-camaro-bismarck-nd
/sale/used-chevrolet-equinox-bismarck-nd
/sale/used-chevrolet-silverado-1500-lt-bismarck-nd
/sale/jeep-cherokee-limited-high-altitude-bismarck-nd
/sale/ram-promaster-1500-bismarck-nd
/sale/used-2020-bismarck-nd
/sale/used-2020-chrysler-bismarck-nd
/sale/used-chevrolet-suburban-bismarck-nd
/sale/used-chevrolet-truck-bismarck-nd
/sale/used-ford-f150-xlt-bismarck-nd
/sale/used-hyundai-elantra-bismarck-nd
/sale/used-infiniti-g37-bismarck-nd
/sale/2020-ram-1500-rebel-bismarck-nd
/sale/2020-ram-2500-bismarck-nd
/sale/4x4-bismarck-nd
/sale/dodge-suv-bismarck-nd
/sale/jeep-4x4-bismarck-nd
/sale/jeep-cherokee-latitude-plus-bismarck-nd
/sale/suv-bismarck-nd
/sale/used-2012-bismarck-nd
/sale/used-2015-bismarck-nd
/sale/used-2017-ford-bismarck-nd
/sale/used-2018-ford-bismarck-nd
/sale/used-2019-ram-1500-laramie-bismarck-nd
/sale/used-4x4-suv-bismarck-nd
/sale/used-audi-a4-bismarck-nd
/sale/used-buick-enclave-bismarck-nd
/sale/used-car-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-ford-fusion-bismarck-nd
/sale/used-ford-truck-bismarck-nd
/sale/used-jeep-cherokee-limited-bismarck-nd
/sale/used-jeep-grand-cherokee-laredo-bismarck-nd
/sale/used-jeep-grand-cherokee-limited-bismarck-nd
/sale/used-jeep-grand-cherokee-overland-bismarck-nd
/sale/used-nissan-frontier-bismarck-nd
/sale/2020-jeep-cherokee-trailhawk-bismarck-nd
/sale/2020-ram-1500-laramie-bismarck-nd
/sale/dodge-durango-gt-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/used-2011-bismarck-nd
/sale/used-2012-ram-bismarck-nd
/sale/used-2014-ram-bismarck-nd
/sale/used-2016-bismarck-nd
/sale/used-2016-ram-bismarck-nd
/sale/used-2018-jeep-compass-bismarck-nd
/sale/used-2019-chevrolet-bismarck-nd
/sale/used-2019-ram-bismarck-nd
/sale/used-2020-gmc-bismarck-nd
/sale/used-cadillac-srx-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-dodge-challenger-rt-scat-pack-bismarck-nd
/sale/used-dodge-grand-caravan-bismarck-nd
/sale/used-dodge-journey-bismarck-nd
/sale/used-ford-explorer-bismarck-nd
/sale/used-ford-mustang-bismarck-nd
/sale/used-ford-super-duty-f350-bismarck-nd
/sale/used-gmc-acadia-bismarck-nd
/sale/used-honda-accord-ex-l-bismarck-nd
/sale/used-hyundai-tiburon-bismarck-nd
/sale/used-jeep-bismarck-nd
/sale/used-jeep-liberty-bismarck-nd
/sale/used-jeep-wrangler-jk-bismarck-nd
/sale/used-ram-1500-rebel-bismarck-nd
/sale/used-ram-2500-tradesman-bismarck-nd
/sale/2020-ram-2500-tradesman-bismarck-nd
/sale/2021-dodge-bismarck-nd
/sale/2021-jeep-suv-bismarck-nd
/sale/awd-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/chrysler-awd-bismarck-nd
/sale/chrysler-pacifica-touring-bismarck-nd
/sale/chrysler-pacifica-touring-l-plus-bismarck-nd
/sale/dodge-challenger-rt-scat-pack-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-compass-80th-special-edition-bismarck-nd
/sale/jeep-compass-altitude-bismarck-nd
/sale/jeep-grand-cherokee-laredo-bismarck-nd
/sale/ram-1500-big-horn-quad-cab-bismarck-nd
/sale/truck-bismarck-nd
/sale/used-2011-ram-bismarck-nd
/sale/used-2012-honda-bismarck-nd
/sale/used-2013-ram-bismarck-nd
/sale/used-2015-ford-bismarck-nd
/sale/used-2016-4x4-truck-bismarck-nd
/sale/used-2016-honda-bismarck-nd
/sale/used-2017-awd-suv-bismarck-nd
/sale/used-2017-ram-bismarck-nd
/sale/used-2018-4x4-truck-bismarck-nd
/sale/used-2018-bismarck-nd
/sale/used-2018-jeep-bismarck-nd
/sale/used-2018-jeep-grand-cherokee-bismarck-nd
/sale/used-2019-4x4-suv-bismarck-nd
/sale/used-2019-bismarck-nd
/sale/used-2020-ram-bismarck-nd
/sale/used-awd-car-bismarck-nd
/sale/used-cadillac-xt4-premium-luxury-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-chevrolet-cruze-bismarck-nd
/sale/used-chevrolet-suv-bismarck-nd
/sale/used-chrysler-200-bismarck-nd
/sale/used-chrysler-awd-bismarck-nd
/sale/used-dodge-bismarck-nd
/sale/used-dodge-car-bismarck-nd
/sale/used-ford-4x4-bismarck-nd
/sale/used-ford-expedition-bismarck-nd
/sale/used-fwd-car-bismarck-nd
/sale/used-honda-accord-ex-bismarck-nd
/sale/used-honda-odyssey-bismarck-nd
/sale/used-hyundai-tucson-bismarck-nd
/sale/used-jeep-wrangler-unlimited-rubicon-bismarck-nd
/sale/used-ram-1500-big-horn-sport-bismarck-nd
/sale/used-ram-1500-express-bismarck-nd
/sale/used-subaru-outback-bismarck-nd
/sale/used-toyota-yaris-bismarck-nd
/sale/used-volkswagen-passat-bismarck-nd
/sale/2020-awd-bismarck-nd
/sale/2020-chrysler-bismarck-nd
/sale/2020-jeep-cherokee-limited-bismarck-nd
/sale/2021-4x4-truck-bismarck-nd
/sale/2021-chrysler-bismarck-nd
/sale/2021-dodge-charger-bismarck-nd
/sale/2021-jeep-renegade-4x4-suv-bismarck-nd
/sale/2021-jeep-renegade-sport-fwd-suv-bismarck-nd
/sale/2021-jeep-renegade-trailhawk-bismarck-nd
/sale/2021-ram-1500-big-horn-bismarck-nd
/sale/2021-ram-1500-big-horn-sport-bismarck-nd
/sale/2021-ram-1500-laramie-bismarck-nd
/sale/2021-ram-2500-big-horn-bismarck-nd
/sale/2021-ram-2500-tradesman-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/cars-bismarck-nd
/sale/chrysler-pacifica-awd-bismarck-nd
/sale/chrysler-pacifica-touring-l-bismarck-nd
/sale/dodge-awd-bismarck-nd
/sale/dodge-car-bismarck-nd
/sale/dodge-charger-sxt-bismarck-nd
/sale/dodge-durango-rt-bismarck-nd
/sale/dodge-durango-rt-bismarck-nd
/sale/dodge-durango-sxt-plus-bismarck-nd
/sale/dodge-journey-se-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-cherokee-bismarck-nd
/sale/jeep-compass-bismarck-nd
/sale/jeep-compass-bismarck-nd
/sale/jeep-compass-bismarck-nd
/sale/jeep-compass-bismarck-nd
/sale/jeep-gladiator-bismarck-nd
/sale/jeep-gladiator-bismarck-nd
/sale/jeep-gladiator-bismarck-nd
/sale/jeep-grand-cherokee-bismarck-nd
/sale/jeep-grand-cherokee-bismarck-nd
/sale/jeep-renegade-bismarck-nd
/sale/jeep-renegade-sport-bismarck-nd
/sale/jeep-suv-bismarck-nd
/sale/jeep-wrangler-bismarck-nd
/sale/jeep-wrangler-bismarck-nd
/sale/jeep-wrangler-bismarck-nd
/sale/jeep-wrangler-unlimited-sahara-altitude-bismarck-nd
/sale/truck-bismarck-nd
/sale/truck-bismarck-nd
/sale/truck-bismarck-nd
/sale/truck-bismarck-nd
/sale/truck-bismarck-nd
/sale/truck-bismarck-nd
/sale/used-2009-bismarck-nd
/sale/used-2011-4x4-truck-bismarck-nd
/sale/used-2011-ford-bismarck-nd
/sale/used-2012-jeep-bismarck-nd
/sale/used-2012-ram-1500-laramie-bismarck-nd
/sale/used-2013-subaru-bismarck-nd
/sale/used-2014-ford-bismarck-nd
/sale/used-2015-ford-f150-xlt-bismarck-nd
/sale/used-2015-fwd-car-bismarck-nd
/sale/used-2015-jeep-grand-cherokee-limited-bismarck-nd
/sale/used-2016-chevrolet-4x4-truck-bismarck-nd
/sale/used-2016-chevrolet-bismarck-nd
/sale/used-2016-chrysler-bismarck-nd
/sale/used-2017-jeep-bismarck-nd
/sale/used-2017-jeep-grand-cherokee-bismarck-nd
/sale/used-2017-ram-1500-laramie-bismarck-nd
/sale/used-2018-jeep-grand-cherokee-limited-bismarck-nd
/sale/used-2018-jeep-grand-cherokee-overland-bismarck-nd
/sale/used-2018-ram-1500-bismarck-nd
/sale/used-2019-chrysler-bismarck-nd
/sale/used-2019-jeep-bismarck-nd
/sale/used-2019-ram-1500-big-horn-bismarck-nd
/sale/used-2019-suv-bismarck-nd
/sale/used-2020-ram-1500-laramie-bismarck-nd
/sale/used-buick-encore-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-cars-bismarck-nd
/sale/used-chevrolet-avalanche-1500-bismarck-nd
/sale/used-chevrolet-silverado-3500hd-bismarck-nd
/sale/used-coupe-bismarck-nd
/sale/used-dodge-bismarck-nd
/sale/used-dodge-bismarck-nd
/sale/used-dodge-bismarck-nd
/sale/used-dodge-charger-gt-bismarck-nd
/sale/used-ford-expedition-el-bismarck-nd
/sale/used-ford-f150-platinum-bismarck-nd
/sale/used-ford-f150-svt-raptor-bismarck-nd
/sale/used-ford-suv-bismarck-nd
/sale/used-honda-passport-bismarck-nd
/sale/used-honda-suv-bismarck-nd
/sale/used-hyundai-tucson-bismarck-nd
/sale/used-jeep-bismarck-nd
/sale/used-jeep-bismarck-nd
/sale/used-jeep-grand-cherokee-summit-bismarck-nd
/sale/used-jeep-wrangler-unlimited-sport-bismarck-nd
/sale/used-kia-bismarck-nd
/sale/used-kia-forte-bismarck-nd
/sale/used-kia-optima-bismarck-nd
/sale/used-kia-sorento-bismarck-nd
/sale/used-nissan-juke-bismarck-nd
/sale/used-nissan-murano-bismarck-nd
/sale/used-ram-1500-slt-bismarck-nd
/sale/used-ram-1500-slt-bismarck-nd
/sale/used-ram-bismarck-nd
/sale/used-ram-bismarck-nd
/sale/used-ram-bismarck-nd
/sale/used-subaru-crosstrek-bismarck-nd
/sale/used-subaru-tribeca-bismarck-nd
/sale/used-toyota-highlander-bismarck-nd
/sale/used-toyota-prius-bismarck-nd
/sale/used-toyota-sequoia-bismarck-nd
/sale/used-toyota-suv-bismarck-nd
/sale/used-toyota-tacoma-bismarck-nd
/sale/used-toyota-tundra-grade-bismarck-nd
/sale/van-bismarck-nd
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)