# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=TO_DATE\().{12}"
test_str = ("TO_DATE('2020-04-25', 'yyyy-mm-dd')\n"
"TO_DATE('2020-04-03', 'yyyy-mm-dd')\n"
"TO_DATE('2020-03-23', 'yyyy-mm-dd')\n"
"TO_DATE('2020-03-11', 'yyyy-mm-dd')\n"
"TO_DATE('2020-04-21', 'yyyy-mm-dd')\n"
"TO_DATE('2020-02-24', 'yyyy-mm-dd')")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.