package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\u00a9|\u00ae|[\u2000-\u3300]|\ud83c[\ud000-\udfff]|\ud83d[\ud000-\udfff]|\ud83e[\ud000-\udfff])`)
var str = `hello
hello ✅
tomorrow`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}