re = /\).*?\(|^.*?\(|\).*?$/
str = 'SOME TEXT (BI1) SOME MORE TEXT (BI17) SOME FINAL TEXT (BI1234)";'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result