using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z]+";
string input = @"my cat is going to the vet";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}