package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-z]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z]+`)
var str = `my cat is going to the vet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}