re = /^[a-z]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z]+/
str = 'my cat is going to the vet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end