$re = '~^[a-z\'-]+|\b(?|my|is|to|the)\b(*SKIP)(*FAIL)|[a-z\'-]+~m';
$str = 'my cat is going to the vet in wilkes-barre.
my cat isn\'t going to the vet today.
doesn\'t your cat need to get a needle soon?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);