package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0|1|-(\g<0>)(\g<0>)`)
var str = `--01-0-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}