$re = '/0|1|-(\g<0>)(\g<0>)/m';
$str = '--01-0-01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);