# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ABC(?!.*MNO)(?=.*XYZ)//gm;t' <<< "Lorem `ABC` ipsum ABC bla MNO bla ipsum ABC asfg 123 hello ABC dd ABC XYZ hello ABC
"