import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+?[0-9]{0,3}-?[0-9]{7,10}$";
final String string = "happy cases:\n"
+ "+919876576543\n"
+ "+91-9876576543\n"
+ "91-9876576543\n"
+ "919876576543\n"
+ "9876576543\n\n"
+ "sad cases:\n"
+ "+91 9773938389\n"
+ "91 9773938389\n"
+ "97739 75647\n"
+ "(+91)-9876576543\n"
+ "(+91)9876576543\n"
+ "(91)9876576543";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}