Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^\+?[0-9]{0,3}-?[0-9]{7,10}$
/
gm
Input 1
1
New
happy cases: +919876576543 +91-9876576543 91-9876576543 919876576543 9876576543 sad cases: +91 9773938389 91 9773938389 97739 75647 (+91)-9876576543 (+91)9876576543 (91)9876576543