import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Askmeoffers deals and coupons";
final String string = "With their unmatched cashback strategy, Askmeoffers focus has been on customer retention and engagement as much as it has been on the acquisition. Build a relationship with the online commerce giant and discover the significant savings you’ll make with every order. And when you thought it couldn’t possibly get any better, guess what? It does - when you buy from Askmeoffers , you’re guaranteed to never miss out on the cashback goodness again. We keep this page updated with all the Askmeoffers coupons and make sure you’ll never have to look for a Askmeoffers promo code anywhere else back. \n\n"
+ "https://askmeoffers.com/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}