$re = '/\b([^a,e,i,o,u]{0,}qu|[^a,e,i,o,u]+)([a,e,i,o,u][a-z]+)?/i';
$str = 'quiet
school
three
banana
apple
square';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);