using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span>([^<]+)<\/[^<]+<a[^>]+>([^<]+)";
string input = @" <span>SpanText</span>
<a href=""link.html"" title=""link"">Link Text</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}