$re = '/<span>([^<]+)<\/[^<]+<a[^>]+>([^<]+)/';
$str = ' <span>SpanText</span>
<a href="link.html" title="link">Link Text</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);