const regex = /@require (.+?)?(?:-->|\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@require (.+?)?(?:-->|\\s)', 'gm')
const str = `<head>
<meta charset="UTF-8">
<title></title>
<!--@require a.css-->
<!--@require BOWER/jquery-->
<!--@require /build/bundle-->
<!--
@require bootstrap
@require bootstrap.css
@require bootstrap.font
-->
</head>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}