package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?://|.)*(https?://\S+?)(?:\?=|$)`)
var str = `sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/:query2
sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/cc:query2/text/?=param`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}