re = /^(?:https?:\/\/|.)*(https?:\/\/\S+?)(?:\?=|$)/m
str = 'sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/:query2
sometextsometexhttp://websites.com/path/subpath/#query1sometexthttp://websites.com/path/subpath/cc:query2/text/?=param'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end