# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(# .*)(&wego)/<a name="$2"><\/a>\n$1 <a href="\/#$2"> βοΈ<\/a>/gm;t' <<< "# Π¨ΠΌΡΠ³Π°ΡΠΎΠ» ΡΠ³ΠΎΠ³ΠΎ &wego
anch \"hi\"
asldkjfasdkl # pookah
askdljf asdjk
asdkalfjasdlkfj
"