re = /\?(.*)/
str = 'http://www.example.com?go1=test1
http://www.example.com?go2=test2
http://www.example.com?go1=test1&go3=test3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end