use strict;
my $str = 'rule "CollectorCar - System Territory - Field Assemble Rule"
when
$section : Section(key == "ccGarageLocation")
$field : Field(key == "territory" && resourceType =="garagingAddress")
then
$field.setOrderNumber(11);
$section.addField($field);
end';
my $regex = qr/\$field\.setOrderNumber\((\d*)\)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}