$re = '/(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/]*)/m';
$str = 'http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;