package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*access-list\s+(\d+)\s*$`)
var str = ` permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}