$re = '/(?<=;)"(([^;]?)([\r\n]?))+"(?![1-9;])/';
$str = '#;Tracker;Statut;Sujet;Mis-à-jour;Catégorie;Description
22915;Feature;New;Additional filetypes (pdf,tif,tiff) for thumbnails generation;2016-05-27 16:49;UI;This patch will allow to generate thumbnails for the first page of pdf/tiff files.
22913;Patch;New;Auto-select fields mapping in Importing;2016-05-27 15:55;Importers;"I hate to select many times in import-mapping.
This patch can auto select by label before you select it."
22912;Defect;Resolved;Selecting a new filter on Activities should not reset the date range;2016-05-27 15:28;Activity view;The attached patch will fix this.
22911;Patch;New;Key/Value List custom field has a bug;2016-05-27 14:04;"";"Import issue with key/value list custom field will throw exception.
The exception is <code>NoMethodError (undefined method `id\' for #<CustomFieldEnumeration......</code>"
22898;Patch;New;!>image.png! generates invalid HTML;2016-05-26 04:35;Text formatting;"Redmine\'s RedCloth (current trunk r15425) generates the following HTML:
Input: <code>!>test.png! Paragraph with floating image</code>
Output: <code><p><div style=""float:right""><img src=""test.png"" alt="""" /></div> Paragraph with floating image</p></code>
The @div@ within the @p@ is not allowed, therefore HTML parsers will autoclose the @p@, the @div@ becomes a sibling to it, the text content will become another sibling and the closing @p@ will trigger another empty @p@ element.
This is what\'s _generated_ in Firefox\'s DOM: <code><p></p><div style=""float:right""><img src=""test.png"" alt=""""/> Paragraph with floating image<p></p></code>.
The attached patch simply adds a @span@ instead of a @div@ and therefore generates the expected DOM structure.
"
22897;Defect;New;Leaving HTML tags in collapse macro instead of showing html_safe formatted text;2016-05-25 14:12;Wiki;"If a HTML content like <h1> for example is added to collapse macro, tags are displayed instead of html formatting it:
<pre>
{{collapse
<h1>This is a block of text that is collapsed by default.</h1>
It can be expanded by clicking a link.
}}
</pre>
And the output looks like:
{{collapse
<h1>This is a block of text that is collapsed by default.</h1>
It can be expanded by clicking a link.
}}
While it should be:
!Screenshot_12.png!
Attached is also diff file to make it work as I suggested in this ticket."
22895;Feature;New;Entering issue comments at the same time shouldn\'t be synced;2016-05-25 11:38;Issues;"Hello in the current Redmine 3.2.2 are issue comments synced.
If one user adds a comment and another user adds a comment in the meantime a issue conflict arise and the comment has to entered again.
The comments are in a different table of the database an adding one record set after another should be no problem nothing is overwritten.
After saving the issue the issue comment history should show the complete history."
22885;Defect;New;"When I register a task linking a ""Parent task"", the system gets too slow";2016-05-24 22:10;Performance;"When I register a task linking a ""Parent task"", the system gets too slow.
The greater the amount of tasks inside the project, slower the tool become to record the tasks using the ""Parent task"" field. If the field ""parent task"" is not used the process is fast.
Eg: I\'m working w';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);