use strict;
my $str = ' (storagegroup:100 AND deviceCustomerNumber 1 > 75)_storageGroup IN ["Internal Event Storage Group"]';
my $regex = qr/.*?storagegroup:100\|Storage Group space used\|.*|.*?cn1=(7[6-9]|8[0-9]|9[0-9]|100).*
/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}