// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)\[\+\] Software in use: (.+?)(?:( - v(\d+.\d+))|$)").unwrap();
let string = "[+] Software in use: Calculator
or, in some cases, the software version number is shown:
[+] Software in use: Calculator - v2.3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}