#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\("(?:[A-Z]|[a-z])[a-z]{3,}"\)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"words.Add("McLaren");//false" & @CRLF & _
"words.Add("Nissan");//true" & @CRLF & _
"words.Add("BMW");//false" & @CRLF & _
"words.Add("Subaru");//true" & @CRLF & _
"words.Add("Maserati");//true" & @CRLF & _
"words.Add("Mercedes Benz");//false" & @CRLF & _
"words.Add("Volkswagen");//true" & @CRLF & _
"words.Add("audi");//true" & @CRLF & _
"words.Add("Alfa Romeo");//false" & @CRLF & _
"words.Add("rollsRoyce");//false" & @CRLF & _
"words.Add("drive");//true"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)