using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(""(?:[A-Z]|[a-z])[a-z]{3,}""\)";
string substitution = @"";
string input = @"
words.Add(""McLaren"");//false
words.Add(""Nissan"");//true
words.Add(""BMW"");//false
words.Add(""Subaru"");//true
words.Add(""Maserati"");//true
words.Add(""Mercedes Benz"");//false
words.Add(""Volkswagen"");//true
words.Add(""audi"");//true
words.Add(""Alfa Romeo"");//false
words.Add(""rollsRoyce"");//false
words.Add(""drive"");//true";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}