$re = '/PI\/(?!master).*/m';
$str = 'testfolder/PI/something
testfolder/PI/anotherthing2
testfolder/PI/master
testfolder/PI/whatever
otherfolder/something_else';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);