Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\((?:[^)(]+|(?R))*+\)
/
g
Input 1
1
New
some text(text here(possible text)text(possible text(more text)))end text