Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\((?:[^)(]+|(?R))*+\)
/
g
Test String
New
some text(text here(possible text)text(possible text(more text)))end text