re = /\((?:[^)(]+|(?R))*+\)/
str = 'some text(text here(possible text)text(possible text(more text)))end text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end