using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)(]*+(?:(?R)[^)(]*)*+\)";
string input = @"some text(text here(possible text)text(possible text(more text)))end text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}