package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^)(]*+(?:(?R)[^)(]*)*+\)`)
var str = `some text(text here(possible text)text(possible text(more text)))end text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}