re = /^(?P<Timecode>(?P<Hours>[0-1][0-9]|2[0-3]):(?P<Minutes>[0-5][0-9]):(?P<Seconds>[0-5][0-9]):(?P<Frames>[0-1][0-9]|2[0-4]))$/
str = '23:59:59:24
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end