import Foundation
let pattern = #"background=['"](?!\s*(http|ftp):\/\/)\/?(?<filename>[^'"]*)['"]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
background="image.gif"
background="/image.gif"
background="images/image.gif"
background="http://host/images/directory/image.gif"
background="images/directory/image.gif"
background='image.gif'
background='/image.gif'
background='images/image.gif'
background='http://host/images/directory/image.gif'
background='/images/directory/image.gif '
background=''
background=' http://host/images/directory/image.gif '
background='test/http://host/images/directory/image.gif'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/mydir/${filename}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)