using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:,\s*)?([^(]+?)\(([^)]+)\)";
string input = @"operator1(value)
operator1(value)
operator1(value), operator2(value)
operator1(value), operator2(value), operator_n(value)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}