#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^(?:(\S+)|\G) (?=.*?(\1[^\n]+))"
Local $sString = "user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user3 jan/12/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user6 aug/06/06" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user1 aug/12/12" & @CRLF & _
"user5 feb/13/13" & @CRLF & _
"user1 dec/14/12" & @CRLF & _
"user1 jul/12/12" & @CRLF & _
"user5 jul/13/13" & @CRLF & _
"user1 jul/14/12" & @CRLF & _
"user2 jun/15/14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")