import re
regex = re.compile(r"^(?:(\S+)|\G) (?=.*?(\1[^\n]+))", flags=re.MULTILINE | re.DOTALL)
test_str = ("user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user3 jan/12/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user6 aug/06/06\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user1 aug/12/12\n"
"user5 feb/13/13\n"
"user1 dec/14/12\n"
"user1 jul/12/12\n"
"user5 jul/13/13\n"
"user1 jul/14/12\n"
"user2 jun/15/14")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")