# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];//gmix;t' <<< "$This->Translate('(?:Droids\');{2}');
$NotTranalate('fdasad');
$this->translate('[a-zA-Z]');
$this->translate('1_category_label');
"