#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mix)[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];"
Local $sString = "$This->Translate('(?:Droids\');{2}');" & @CRLF & _
"$NotTranalate('fdasad');" & @CRLF & _
"$this->translate('[a-zA-Z]');" & @CRLF & _
"$this->translate('1_category_label');" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)