$re = '/[$]this->translate[(]\'((?:[^\'\\\\]|\\\\.|\'\')*)\'[)];/mix';
$str = '$This->Translate(\'(?:Droids\\\');{2}\');
$NotTranalate(\'fdasad\');
$this->translate(\'[a-zA-Z]\');
$this->translate(\'1_category_label\');
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;