# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
[$]this->translate[(]'((?:[^'\\]|\\.|'')*)'[)];
"""
test_str = ("$This->Translate('(?:Droids\\');{2}');\n"
"$NotTranalate('fdasad');\n"
"$this->translate('[a-zA-Z]');\n"
"$this->translate('1_category_label');\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.