#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(html) *(\+=) *\"<{1}(i|I)(m|M)(g|G) *(s|S)(r|R)(c|C) *= *'{0,1}" *\+ *(val.imageLink) *\+ *" *'{0,1} *>";"
Local $sString = "html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html += "<img src ='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink +" ' >";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"html+= "<img src='"+val.imageLink+"'>";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"html+="<img src='>"+val.imageLink+"'>";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")