package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*((true|false)\s*,?\s*)*$`)
var str = ` false , true ,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}