#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([Ss][Ll][Nn])\s+(\d+)\s+[Gg][Rr][Pp]\s+\d+\s+[S][T][Y][P]\s+\S*\s"
Local $sString = "SLN 4 GRP 662 STYP 'TZ' SNO 1037 DRX -3.41018E-15 2.25685E-15 -1 XFLG 'PLA' "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")