// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"goTo_(\d+)_(\d+)_(\d+)").unwrap();
let string = "param-out goTo goTo_1_1_1 goTo_2_1_2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}