// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)customfield_11301(.*?)customfield_10730").unwrap();
let string = " \"customfield_11300\": null,
\"customfield_11301\": [
{
\"self\": \"xxxxxxxx\",
\"value\": \"xxxxxxxxx\",
\"id\": \"10467\"
}
],
\"customfield_10730\": null,
\"customfield_11302\": null,
\"customfield_10720\": 0.0,
\"customfield_11300\": null,
\"customfield_11301\": [
{
\"self\": \"zzzzzzzzzzzzz\",
\"value\": \"zzzzzzzzzzz\",
\"id\": \"10467\"
}
],
\"customfield_10730\": null,
\"customfield_11302\": null,
\"customfield_10720\": 0.0,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}